Sub Menus already displayed by default

Home Forums Pro Support Sub Menus already displayed by default

This topic contains 6 replies, has 2 voices, and was last updated by  Anonymous 1 year, 9 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #69047

    Anonymous

    Hello

    I’m trying out the responsive menu plugin.
    I have the problem, that the menu structure of the mobile menu just shows every single navigation point from the start. There are no arrows or something to click on to expand.
    Could you have a look and maybe see what’s causing the issue?

    Thank you very much for your help and kindest regards
    Marc

    #69052
    Peter Featherstone
    Peter Featherstone
    Participant

    Hey Marc,

    I am more than happy to take a look but unfortunately you haven’t provided me with a link to your page.

    Please provide and I will take a look.

    Peter

    #69051

    Anonymous

    Oh sorry, I thought it was enough if I just put it under website.
    There you go: https://dev.swisstriathlon.ch/

    #69050
    Peter Featherstone
    Peter Featherstone
    Participant

    Hey Marc,

    Unfortunately not. As what you are describing is an issue which is not supposed to be happening it is likely something specific on your site stopping it from working.

    Looking at the HTML output of my menu on your site, something in your theme or another plugin is completely overwriting the class names of my plugin which is why it is not working.

    Can you try disabling all plugins on your site and see if that fixes it. If it does, then you can activate all plugins again one by one until the issue returns, at which point you know the offending plugin.

    If disabling all plugins doesn’t fix it then you will need to deactivate your theme and switch to a base WordPress one. If this fixes the issue then you will know that the theme is what is overwriting my classes.

    Please let me know your findings.

    Peter

    #69049

    Anonymous

    Hey Peter

    Thank you for your help!
    It is the theme indeed that is overwriting all the classes.

    Kindest regards
    Marc

    #69048
    Peter Featherstone
    Peter Featherstone
    Participant

    Hey Marc,

    Great that you found the cause, but not great that it is your theme.

    Hopefully the theme authors can change their solution by adding their classes to just their menus or just appending their classes to menu items rather than overwriting other plugins classes.

    Let me know how you get on!

    Peter

Viewing 6 posts - 1 through 6 (of 6 total)

The topic ‘Sub Menus already displayed by default’ is closed to new replies.